Back to overview
Resolved
Database updates
Aug 30, 2026 at 10:30am UTC
–
Aug 30, 2026 at 12:30pm UTC
Affected services
Balerion App + API
Resolved
Aug 30, 2026 at 12:30pm UTC
Maintenance ended
Affected services
Created
Aug 30, 2026 at 10:30am UTC
we are sorry for longer loading times than usual.
To upgrade our performance and get even faster loading times than before, we are currently updating our databases.
Affected services